BETA

14th February 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [14/02/19 04:09 AM] with 'Major Outage'

Issue has been resolved at [14/02/19 04:10 AM]