BETA

8th October 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [08/10/17 01:00 AM] with 'Partial Outage'

Issue has been resolved at [08/10/17 01:02 AM]