Exotel Status Board
Home
Dashboard
BETA
15th February 2024
West Bengal
Issue observed for 'Outgoing Calls' in West Bengal Region
Identified at [15/02/24 03:40 PM] with 'Major Outage'
Issue has been resolved at [16/02/24 01:55 AM]