BETA

4th September 2016

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [04/09/16 12:14 AM] with 'Major Outage'

Issue has been resolved at [04/09/16 12:17 AM]