Exotel Status Board
Home
Dashboard
BETA
13th February 2024
West Bengal
Issue observed for 'Outgoing Calls' in West Bengal Region
Identified at [13/02/24 04:40 PM] with 'Major Outage'
Issue has been resolved at [13/02/24 10:25 PM]