BETA

14th February 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [14/02/19 01:52 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/02/19 01:56 AM]