BETA

5th October 2017

Andhra Pradesh Issue observed for 'Incoming Calls' in Andhra Pradesh Region

Identified at [05/10/17 03:43 PM] with 'Major Outage'

Issue has been resolved at [05/10/17 04:06 PM]