BETA

5th October 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [05/10/17 12:48 PM] with 'Partial Outage'

Issue has been resolved at [05/10/17 03:15 PM]