Exotel Status Board
Home
Dashboard
BETA
9th February 2024
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [09/02/24 01:40 PM] with 'Major Outage'
Issue has been resolved at [09/02/24 01:45 PM]