BETA

8th February 2024

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [08/02/24 01:11 PM] with 'Partial Outage'

Issue has been resolved at [08/02/24 01:35 PM]