BETA

29th September 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [29/09/17 10:04 AM] with 'Partial Outage'

Issue has been resolved at [29/09/17 10:06 AM]