BETA

26th September 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [26/09/17 12:45 PM] with 'Partial Outage'

Issue has been resolved at [26/09/17 01:01 PM]