BETA

25th September 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [25/09/17 03:07 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [25/09/17 03:14 PM]