Exotel Status Board
Home
Dashboard
BETA
2nd February 2024
Karnataka
Issue observed for 'Outgoing Calls' in Karnataka Region
Identified at [02/02/24 03:35 PM] with 'Major Outage'
Issue has been resolved at [02/02/24 03:45 PM]