Exotel Status Board
Home
Dashboard
BETA
1st February 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [01/02/24 08:45 PM] with 'Major Outage'
Issue has been resolved at [01/02/24 08:51 PM]