BETA

25th September 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [25/09/17 02:50 PM] with 'Partial Outage'

Issue has been resolved at [25/09/17 02:57 PM]