BETA

14th February 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [14/02/19 12:31 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/02/19 12:39 AM]