Exotel Status Board
Home
Dashboard
BETA
25th January 2024
Delhi
Issue observed for 'Incoming Calls' in Delhi Region
Identified at [25/01/24 11:52 AM] with 'Major Outage'
Issue has been resolved at [25/01/24 11:56 AM]