Exotel Status Board
Home
Dashboard
BETA
24th January 2024
Andhra Pradesh
Issue observed for 'Incoming Calls' in Andhra Pradesh Region
Identified at [24/01/24 11:30 PM] with 'Major Outage'
Issue has been resolved at [24/01/24 11:35 PM]