Exotel Status Board
Home
Dashboard
BETA
23rd January 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [23/01/24 04:50 AM] with 'Major Outage'
Issue has been resolved at [23/01/24 04:56 AM]