BETA

21st September 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [21/09/17 10:07 AM] with 'Partial Outage'

Issue has been resolved at [21/09/17 10:08 AM]