BETA

13th February 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [13/02/19 11:55 PM] with 'Major Outage'

Issue has been resolved at [13/02/19 11:56 PM]