BETA

13th February 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [13/02/19 11:49 PM] with 'Partial Outage'

Issue has been resolved at [13/02/19 11:52 PM]