Exotel Status Board
Home
Dashboard
BETA
19th January 2024
West Bengal
Issue observed for 'Outgoing Calls' in West Bengal Region
Identified at [19/01/24 10:15 PM] with 'Major Outage'
Issue has been resolved at [19/01/24 11:51 PM]