BETA

20th September 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [20/09/17 01:18 PM] with 'Partial Outage'

Issue has been resolved at [20/09/17 01:24 PM]