BETA

13th February 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [13/02/19 11:45 PM] with 'Major Outage'

Issue has been resolved at [13/02/19 11:46 PM]