BETA

20th September 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [20/09/17 01:33 AM] with 'Major Outage'

Issue has been resolved at [20/09/17 01:34 AM]