BETA

13th February 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [13/02/19 11:26 PM] with 'Partial Outage'

Issue has been resolved at [13/02/19 11:27 PM]