Exotel Status Board
Home
Dashboard
BETA
19th January 2024
Chennai
Issue observed for 'Incoming Calls' in Chennai Region
Identified at [19/01/24 02:10 AM] with 'Major Outage'
Issue has been resolved at [19/01/24 02:15 AM]