BETA

16th September 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [16/09/17 12:08 AM] with 'Major Outage'

Issue has been resolved at [16/09/17 12:09 AM]