Exotel Status Board
Home
Dashboard
BETA
18th January 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [18/01/24 11:15 PM] with 'Major Outage'
Issue has been resolved at [18/01/24 11:20 PM]