Exotel Status Board
Home
Dashboard
BETA
18th January 2024
Chennai
Issue observed for 'Incoming Calls' in Chennai Region
Identified at [18/01/24 08:25 PM] with 'Major Outage'
Issue has been resolved at [18/01/24 08:30 PM]