BETA

15th September 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [15/09/17 07:38 PM] with 'Partial Outage'

Issue has been resolved at [15/09/17 07:39 PM]