BETA

13th February 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [13/02/19 11:07 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [13/02/19 11:11 PM]