BETA

13th February 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [13/02/19 11:05 PM] with 'Partial Outage'

Issue has been resolved at [13/02/19 11:08 PM]