BETA

13th February 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [13/02/19 11:04 PM] with 'Partial Outage'

Issue has been resolved at [13/02/19 11:07 PM]