Exotel Status Board
Home
Dashboard
BETA
17th January 2024
Karnataka
Issue observed for 'Outgoing Calls' in Karnataka Region
Identified at [17/01/24 01:50 PM] with 'Major Outage'
Issue has been resolved at [17/01/24 02:07 PM]