BETA

15th September 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [15/09/17 07:32 PM] with 'Major Outage'

Issue has been resolved at [15/09/17 07:33 PM]