Exotel Status Board
Home
Dashboard
BETA
12th January 2024
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [12/01/24 08:32 AM] with 'Major Outage'
Issue has been resolved at [12/01/24 08:36 AM]