BETA

31st August 2016

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [31/08/16 12:13 AM] with 'Major Outage'

Issue has been resolved at [31/08/16 12:17 AM]