BETA

11th January 2024

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [11/01/24 04:20 PM] with 'Major Outage'

Issue has been resolved at [11/01/24 05:20 PM]