BETA

15th September 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [15/09/17 07:32 PM] with 'Partial Outage'

Issue has been resolved at [15/09/17 07:48 PM]