BETA

15th September 2017

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [15/09/17 09:57 AM] with 'Major Outage'

Issue has been resolved at [15/09/17 09:58 AM]