Exotel Status Board
Home
Dashboard
BETA
9th January 2024
Chennai
Issue observed for 'Incoming Calls' in Chennai Region
Identified at [09/01/24 01:20 AM] with 'Major Outage'
Issue has been resolved at [09/01/24 01:30 AM]