BETA

15th September 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [15/09/17 09:51 AM] with 'Partial Outage'

Issue has been resolved at [15/09/17 10:07 AM]