BETA

15th September 2017

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [15/09/17 04:30 AM] with 'Major Outage'

Issue has been resolved at [15/09/17 04:31 AM]