BETA

15th September 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [15/09/17 04:30 AM] with 'Partial Outage'

Issue has been resolved at [15/09/17 04:31 AM]