Exotel Status Board
Home
Dashboard
BETA
26th December 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
a year ago
Identified at [26/12/23 02:40 PM] with 'Major Outage'
Issue has been resolved at [26/12/23 02:45 PM]