BETA

15th September 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [15/09/17 04:29 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [15/09/17 04:31 AM]