BETA

12th September 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [12/09/17 12:31 PM] with 'Partial Outage'

Issue has been resolved at [12/09/17 12:32 PM]